can t load required directx libraries

I recently installed windows 8 and installed directx sdk jun 2010 on it. However when I try to start a program on it gives me an error:

Error: «couldnt find d3dx9.lib» or «couldnt find d3dx11.h»

This error was in directx own sample projects also. I found an article on the internet that said these kind of libraries(every thing with x in it :d) are not supported any more. I commented all code that needed these libraries, it worked and my program ran.

Question:

What is it and how should I work with it? Are all these libraries are not supported? I found vs 2012 added a new framework: direct 3d app and direct 2d app. I made a project in it but I hardly could understand the code and how it works. Is it a new way of working with directx or is the best to make an empty project?

Особенности трейнера для GTA V:
— выбор скинов (в том числе и любых животных);
— телепорт в любое место (нужно установить маркер);
— непобедимость;
— восстановление игрока;
— добавить 1.000.000 $;
— управление уровнем розыска;
— игнор полицией;
— неограниченные спецспособности;
— бесшумность;
— быстро плавать или бежать;
— супер-прыжок;
— ускорение для транспорта;
— спавн автомобиля;
— покраска в случайный цвет;
— восстановление автомобиля;
— броня для автомобиля;
— всё оружие;
— ракеты на автомобиле;
— нет перезарядки;
— огненные пули;
— взрывные пули;
— взрывной удар;
— переключатель случайных поездов/лодок/и т.д.;
— час вперед или назад;
— мир на паузе;
— синхронизация времени игры с реальным временем;
— управление ветром;
— выбор погоды;
— смена песни на радио;
— скрыть мини-карту.

Управление:

F4-Активация трейнера
Num 4,Num 8,Num 6, Num 2- Управление в меню трейнера
Num 5-Выбор
Num 0-Выход из меню трейнера

Трейнер не работает в онлайне!

Ошибка: SCRIPT HOOK V CRITICAL ERROR

SCRIPT HOOK V CRITICAL ERROR, данная ошибка появляется при запуске гта 5, из-за чего она?

Вероятней всего у вас лицензионная игра, и всего скорее вышло новое обновление для гта 5, как итог у игры стала другая версия.

Script Hook v – это специальный мод необходимый для запуска других модов для игры, и этот мод у вас устарел, как видно на картинке он указал, какие версии игры поддерживает данная версия Script Hook v, всего скорее у вас более новая версия игры.

Что делать и как исправить данную ошибку?

Вам необходимо обновить файлы Script Hook v на более новые, т.е заново скачать архив с Script Hook v, и перенести файлы dinput8.dll и ScriptHookV.dll в папку с игрой, подтвердить замену файлов.

Ошибка SCRIPT HOOK V CRITICAL ERROR

Что делать если самая последняя версия на странице загрузки не помогает?

Новая версия Script Hook v выходит через 1-3 дня после обновления игры, если на странице скачивания Script Hook v нет более новой версии, вам придется подождать.

Как поиграть если новая версия Script Hook v еще не вышла?

Вариант есть, просто удалите файлы dinput8.dll и ScriptHookV.dll из папки с игрой, но у вас перестанут работать моды, в том числе трейнеры.
А так же при запуске игры может появиться ошибка ERR_GEN_INVAL >

Помогла ли вам наша инструкция? Делитесь мнением в комментариях.

Понравилась статья? Поделиться с друзьями:
Vkontakte.INFO
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: