1с скд программно добавить отбор

IKSparrow 25.10.2012 13:44
Прочитано: 33024
Код следующий:

Мой отбор ни фига не учитывается. Что не так делаю?

Yandex
Возможно, вас также заинтересует
Mokey 25.10.2012 13:58
Ответ № 1
ВидОбъекта.ПравоеЗначение = «Справочник.ИсторияПользователей»;
вот это вот что такое? тут должно быть значение вида объекта, т.е. ссылка на элемент справочника.
IKSparrow 25.10.2012 14:01
Ответ № 2
(1) Нееет, там тип строка. Т.ё. не сам элемент какого-то справочника, а наименование справочника. Вернее наименование его типа, как оно записано в определённом регистре.
Gnost 25.10.2012 16:00
Ответ № 3
Пользователь @Monkey правильно вам говорит

ЭлементОтбораКомпоновкиДанных.ПравоеЗначение (DataCompositionFilterItem.RightValue)
ЭлементОтбораКомпоновкиДанных (DataCompositionFilterItem)
ПравоеЗначение (RightValue)
Использование:

Чтение и запись.
Описание:

Содержит правое значение элемента отбора.

Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.
Примечание:

Тип правого значения может быть полем, остальные варианты зависят от левого значения. Это может быть его тип левого значения, либо, если слева выбрано поле, может использоваться тип поля.

also Что-то вроде FAQ Отзывов (4) В закладки

Здравствуйте! Не могу найти ответа на такой вопрос. Везде вот примеры по отборам только основным. А как быть с отбором по группировке. У меня вот такая проблемма: в настройках СКД добавлены отборы по группировкам, при выборе определенных значений реквизитов на форме отчета нужно сделать так, чтобы отборы включались или отключались. Для основного отбора всё понятно как это сделать КомпоновщикНастроек.Настройки.Отбор.Элементы[индекс], но в этот массив элементов не попадают отборы по группировкам. Как программно добраться до галочки “Использовать” у отбора группировки ?

Посмотри в КомпоновщикНастроек.Настройки.Структура

ЭлементОтбора = ПолучитьЭлементОтбора(“ИмяПредставлениеОтбора”);
ЭлементОтбора.Использование = Ложь;
//___________________________________________________________
Функция ПолучитьЭлементОтбора(ПредставлениеОтбора)
Для каждого ЭлементОтбора Из КомпоновщикНастроек.Настройки.Отбор.Элементы Цикл
Если ЭлементОтбора.Представление = ПредставлениеОтбора Тогда
Возврат ЭлементОтбора;
КонецЕсли;
КонецЦикла;
Возврат “”;
КонецФункции

also
А вы не знаете как программно устанавливать группировки и отключать их?

Трекбеки/Пинги

  1. payday loans — payday loans. Subscribed to your weblog, many thanks.

Оставить комментарий Отменить ответ

Для отправки комментария вам необходимо авторизоваться.

Постоянно нужен и постоянно забывается код как программно добавить или изменить параметр или отбор СКД.

Код можно использовать при открытии формы, чтобы задать начальные настройки вычислив их по вашему особому алгоритму и т.д., так как не всегда параметры и отборы настолько просты, что можно их вложить в СКД.

Понравилась статья? Поделиться с друзьями:
Vkontakte.INFO
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: