1с построитель отчета отбор

Примеры по программированию в 1с 7.7, 8.1, 8.2

понедельник, 30 марта 2015 г.

Копирование отборов построителя отчета

1)Первый построитель:
.
Построитель.Параметры.Вставить(«Кон», КонПериода);
Построитель.Параметры.Вставить(«Нач», НачПериода);
Построитель.Выполнить();

Отбор = Новый Массив;
для Каждого стр из Построитель.Отбор Цикл
СтрО = Новый Структура;
СтрО.Вставить(«ВидСравнения»,стр.ВидСравнения);
СтрО.Вставить(«Значение»,стр.Значение);
СтрО.Вставить(«ЗначениеПо»,стр.ЗначениеПо);
СтрО.Вставить(«ЗначениеС»,стр.ЗначениеС);
СтрО.Вставить(«Имя»,стр.Имя);
СтрО.Вставить(«Использование»,стр.Использование);
СтрО.Вставить(«Представление»,стр.Представление);
СтрО.Вставить(«ПутьКДанным»,стр.ПутьКДанным);
СтрО.Вставить(«ТипЗначения»,стр.ТипЗначения);
Отбор.Добавить(СтрО);
КонецЦикла;

В=Построитель.Результат.Выбрать();
.
2)Следующий построитель:
Построитель.Параметры.Вставить(«Нач»,НачПериода);
Построитель.Параметры.Вставить(«Кон»,КонПериода);

Для каждого стрО Из Отбор Цикл
Нов = Построитель.Отбор;
Если Нов.Найти(СтрО.Имя)<>Неопределено Тогда
Продолжить;
КонецЕсли;
Нов_ = Нов.Добавить(СтрО.Имя);
ЗаполнитьЗначенияСвойств(Нов_,СтрО);
КонецЦикла;

В = Построитель.Результат.Выбрать();
Пока В.Следующий() Цикл

Платформа:

Конфигурация:

Иногда при создании отчётов возникает необходимость добавления в отчёт отборов со стандартными условиями равно, не равно, в списке, в группе и т.д. При этом нет возможности использовать систему компоновки данных.
В данной статье будет рассказано, как это сделать без использования СКД.

1. Создаёте новый внешний отчёт.

2. Добавляете в него реквизит типа ПостроительОтчета.

3. Создаёте новую форму отчёта.

4. На форме размещаете элемент управления Табличное поле с типом значения Отбор.

5. Привязываете созданный элемент управления к свойству Отбор реквизита отчёта, созданного в п.2.

6. В процедуре формы ПриОткрытии прописываете инициализацию реквизита-построителя отчёта. Обязательно задаёте текст построителя отчёта. Например:

Однако, если в запросе есть параметры, то после заполнения настроек они тоже попадут в отборы.
Условия в запросе, заключённые в фигурные скобки <>, будут работать только при включении соответствующих отборов в пользовательском режиме.

7. Сохраняете отчёт.

8. Открываете отчёт в пользовательском режиме и устанавливаете отборы по своему усмотрению привычным способом. Поля, не отмеченные галками, не будут участвовать в отборах.

• 1С8 Самоучитель. » 1С8 Самоучитель. Консоль отчетов. Язык построителя отчета.

Язык построителя отчета — инструмент программиста.

Язык построителя отчета используется в 1С — запросах. Конструкции языка построителя отчета управляют формированием отчета.

Конструкции построителя заключаются в фигурные скобки.

ВЫБРАТЬ — в этом предложении описываются поля, которые пользователь сможет выбирать для вывода.

ГДЕ — описываются поля, на которые пользователь сможет накладывать ограничения.

— Позволяет пользователю в настройке отчета выбирать поля управления порядком сортировки (закладка «Сортировка»).

ИТОГИ ПО — описываются поля, по которым будут выводиться итоговые значения. После всех этих элементов через запятую перечисляются поля, которые могут являться как «реальными» полями, так и псевдонимами полей из списка выборки. После поля можно указывать псевдоним поля для построителя отчета.

Если после поля поставить «.*», то это будет означать, что кроме самого поля построитель даст возможность использовать и все поля «через точку» от данного поля.

В данном примере, в отчете пользователь сможет выбирать в качестве измерения не только номенклатуру но также и все ее реквизиты, например «Номенклатура.ОсновнойПоставщик». Кроме основных элементов, построитель принимает элементы, записанные в параметрах виртуальных таблиц. В таких случаях тип полей зависит от типа параметра, в котором располагаются элементы.

Предлагаем решение Ваших задач 1С.

Внедрение 1С:

  • Организуем вам индивидуальное экспресс обучение программам 1С.
  • Мы поможем Вам начать работать с программами 1С.
  • Мы поможем Вам настроить ваши отчеты в 1С.
  • Установим и настроим 1С под ваши задачи.
  • Поможем сделать ввод начальных остатков по складам и контрагентам
  • Перенесем данные из старых систем.
  • Подскажем как избежать ошибок.

Доработка и сопровождение 1С:

  • Доработаем существующие или создадим новые печатных формы и документы.
  • Разработаем внешние отчеты по Вашим требованиям.
  • Напишем внешние обработоки по загрузке документов из учетных (торговых) систем в бухгалтерию.
  • Разработаем приложения для выгрузки данных на сайты.

Ориентировочная стоимость работ программиста 1С : 500 р. за 1 час работы.

Звоните: 8 916 710 83 51 Ольга

© j008.ru 2014 Обратная связь: j008@j008.ru

Понравилась статья? Поделиться с друзьями:
Vkontakte.INFO
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: