1с поиск в табличной части документа

//Корректировать строку табличной части документа
//»ОС» — наименование табличной части
Тч = Док . ОС ;
Тч[ 0 ] . НалоговаяГруппаОС = Справочники . НалоговыеГруппы . НайтиПоНаименованию ( «Четвертая (с 2004 г)» );
Док . Записать ( РежимЗаписиДокумента . Проведение );

//——————————————————————
//Поиск в табличной части документа
//»Платежи» — наименование табличной части
Сообщить ( Док . Платежи . Найти ( ТоЧтоНужноНайти , «РеквизитВТабЧастиГдеИскатьЗначение» )[ «РеквизитВТабЧастиОткудаВзятьЗначение» ]);

//——————————————————————
//Cделать текущей строку табличной части формы документа
//»Выписки» — наименование табличной части
ЗаписьВыписка = ДокБанковскаяВыписка . Выписки . Добавить ();
ЗаписьВыписка . Реквизит1 = «Реквизит1» ;
ЗаписьВыписка . Реквизит2 = «Реквизит2» ;

ФормаВыписка = ДокБанковскаяВыписка . ПолучитьФорму ( «ФормаДокумента» );
ФормаВыписка . ЭлементыФормы . Выписки . ТекущаяСтрока = ЗаписьВыписка ;
ФормаВыписка . Открыть ();

//——————————————————————
//Удалить записи из табличной части документа с помощью структуры
Отбор = Новый Структура ;
Отбор . Вставить ( «КодОбъекта» , ЗначениеКодОбъекта );

Документ = Документы . ПриходнаяНакладная . НайтиПоНаименованию ( «Наименование» ). ПолучитьОбъект ();

//Удаляем записи табличной части
ЗаписиТабЧасти = Документ [ «НазваниеТабЧасти» ]. НайтиСтроки ( Отбор );
Для Каждого ЗаписьТабЧасти Из ЗаписиТабЧасти Цикл
Документ [ «НазваниеТабЧасти» ]. Удалить ( ЗаписьТабЧасти );
КонецЦикла;

//——————————————————————
//Удалить строки (записи) из табличной части документа в цикле (при переборе)
Док = ДокБанковскаяВыписка . ПолучитьОбъект ();
КоличествоЗаписей = Док . Выписки . Количество ();
КоличествоОборотов = 0 ;
Для ъ = 0 По КоличествоЗаписей — 1 Цикл
КоличествоОборотов = КоличествоОборотов + 1 ;

Если Док . Выписки [ ъ ]. ИмяПоля = Истина Тогда
Док . Выписки . Удалить ( Док . Выписки [ ъ ]);
ъ = ъ — 1 ;
КонецЕсли;

Если КоличествоОборотов = КоличествоЗаписей Тогда
Прервать;
КонецЕсли;
КонецЦикла;
Док . Записать ();

Осуществляет поиск всех строк таблицы значений, удовлетворяющих заданным условиям поиска.

Синтаксис

Метод НайтиСтроки() имеет следующий синтаксис:

А также альтернативный англоязычный синтаксис:

Параметры

Описание параметров метода НайтиСтроки() :

Имя параметра Тип Описание
ПараметрыОтбора Структура Задает условия поиска: ключ структуры определяет имя колонки, по которой будет осуществляться поиск, а значение структуры — искомое значение.
Жирным шрифтом выделены обязательные параметры

Возвращаемое значение

Массив
Массив найденных строк таблицы значений, соответствующих условиям поиска.

Описание

Метод НайтиСтроки() осуществляет поиск строк таблицы значений, удовлетворяющих заданным условиям поиска. В отличие от метода ТаблицаЗначений.Найти(), возвращает все найденные строки.

Доступность

Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).

Пример использования

Пример кода с использованием метода НайтиСтроки() :

Этой статьей я продолжаю серию заметок об эффективных приемах работы в 1С:Бухгалтерия 8.3. Рассказываю о хитростях, которые мало кто знает и ещё меньше людей используют в своей работе. Приемы, о которых пойдет речь, способны существенно сэкономить время и повысить вашу квалификацию как специалиста. Первая часть доступна здесь.
п

Прием №4: Поиск в текущей колонке сразу после начала набора текста.

Как вы ещё не пользуетесь этой потрясающей возможностью? В любом журнале (будь-то справочник или документы) выделите любую строчку в любом столбце и просто начинайте набирать текст.

Система автоматически будет отбирать строки, в которых содержится вводимое вами значение в одном из столбцов:

Если нужно отменить фильтр — нажмите кнопку Esc на клавиатуре или на крестик в поле поиска:

Но что, если нам нужно искать не во всех колонках, а только в конкретной?

Для поиска в текущей (выделенной) колонке используйте комбинацию Alt + F или пункт меню «Ещё»->»Расширенный поиск»:

Для мгновенного отбора (без отображения диалогового окна) по текущей колонке и по выделенному в ней значению используйте комбинацию Ctrl + Alt + F или пункт меню «Ещё»->»Найти. «.

Например, давайте отберём все документы в номере которых встречается цифра 8. Для этого выделим столбец «Номер» в любой строке и нажмём Alt + F.

В открывшемся окне наберём цифру 8 и нажмём «Найти»:

Отлично, в списке остались документы в номере которых (в любой позиции) содержится цифра 8:

Для отмены отбора нажмём комбинацию Ctrl + Q или удалим отбор с верхней панели (крестик):

Внимание! Если поиск не срабатывает (получается пустой отбор) — вероятно у вас включён полнотекстовый поиск и не обновлён его индекс.

Полнотекстовый поиск настраивается в разделе «Администрирование» пункт «Поддержка и обслуживание»:

Далее регламентные операции и уже здесь или отключаем полнотекстовый поиск или обновляем его индекс (пункт «Настроить» кнопка «Обновить индекс»):

Прием №5: Ввод в поле ввода по строке.

Пусть вам требуется забить поле контрагент в документе «Поступление товаров и услуг» и вы знаете, что контрагент называется как-то на «аэро».

И вы вместо того, чтобы выбирать контрагента из списка, просто возьмите и начните в поле ввода контрагент набирать текст «аэро». Как видите система сама подсказывает возможные варианты контрагентов, которые начинаются с этих букв. Искомый аэрофлот найден — осталось просто выбрать его.

И так можно в любых полях!

Прием №6: Суммирование выделенных ячеек в отчетах.

Просто выделяйте нужные ячейки мышкой — сумма автоматически отобразится в поле указанном на рисунке. А если нужно выделить ячейки не находящиеся рядом — используйте клавишу CTRL. Зажмите её и выделяйте нужные ячейки в отчете, чтобы получить их сумму.

Прием №7: Сохраняйте любые печатные формы в любом удобном формате.

Любой отчет или печатную форму документа можно сохранить в подходящем формате на компьютер. Просто сформируйте печатную форму и нажмите на значок дискеты в верхней части окна программы.

Теперь выберите имя и формат для документа. Это может быть excel, word, pdf, html и многие другие популярные форматы.

Прием №8: Групповая печать документов.

Прием №9: Печать журнала или табличной части документа.

Продолжение здесь (ч. 3).

Мы молодцы, на этом всё

Кстати, подписывайтесь на новые уроки.

С уважением, Владимир Милькин (преподаватель школы 1С программистов и разработчик обновлятора).

Подписывайтесь и получайте новые статьи и обработки на почту (не чаще 1 раза в неделю).

Вступайте в мою группу ВКонтакте, Одноклассниках, Facebook или Google+ — самые последние обработки, исправления ошибок в 1С, всё выкладываю там в первую очередь.

Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.

Нажмите одну из кнопок, чтобы поделиться:

Понравилась статья? Поделиться с друзьями:
Vkontakte.INFO
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: